// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?miuU)^(.*)(\(([^\)]*)%(\s)*\)?)?$").unwrap();
let string = "Produitun (19 %)
produit 2 ( 20%)
produit numéro 3 (5% )
produitsansprct
produit Quatre (2.1%)
autre produit sans prct
produit 5 (0.1%)
produit 6 (mélange produit4 (5%) produit 2 (7%))
produit 7 (15,4%)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}