using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"”([^”]*?Voldemort.*?”|.*?”(*SKIP)(*FAIL))";
string input = @"”voldemort is angy” said Voldemort. ”no voldi” ”again” voldemort ” Voldemort” Voldemort ";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}