package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)”([^”]*?Voldemort.*?”|.*?”(*SKIP)(*FAIL))`)
var str = `”voldemort is angy” said Voldemort. ”no voldi” ”again” voldemort ” Voldemort” Voldemort `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}