$re = '/\*[^\W_\n]+_[a-z]\d+\b|(\d)/m';
$str = '*specially_x00123 hello23 the2e are 13 5.12apples named 31st';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);