$re = '/\/(?<A>\d+)(?:\/(?<B>\d+))?/';
$str = '/1234/5678
/1234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);