import Foundation
let pattern = #"((http|ftp)s?:.*?) "#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
< Div > 
 	< div id = "header_col2" >  
 		< a href = "index_en.xhtml" title = "Angol version" >  
 			< img src = "eng.jpg" alt = "Angol" height = "25" width = "48 " / > 
 		< / a > 
 	< / div > 
 < / div > 
 < div id = " clear " > 
 < hr / > 
 	<h2 > Some links < / h2 >
 	< P > 
 		< a href = "http://www.math.bme.hu/algebra " > Department of Algebra < / a > < br / > 
 		< a href = "http://www.math.bme.hu/ " > matematics institude < / a > < br / > 
 		< a href = " http://www.bme.hu/ " > BME < / a >  < br / > 
 		< a href = " http://www.bme.hu/~kk0v4cs " > Something else < / a >  <br / > 
 	< / p> 
 < / div >
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
    var groups: [String] = []
    for rangeIndex in 1 ..< match.numberOfRanges {
        let nsRange = match.range(at: rangeIndex)
        guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
        let string = (testString as NSString).substring(with: nsRange)
        groups.append(string)
    }
    if !groups.isEmpty {
        result.append(groups)
    }
}
print(result)