$re = '/^(\2tic|(tac))+$/m';
$str = 'tactactic';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);