use strict;
my $str = '0,000001
0,000000001
1,00
1.000,00
0,1000000';
my $regex = qr/^(?:[1-9]\d{0,2}(?:\.\d{3})*,\d{2}|0\d*,\d+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}