// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[1-9]\d{0,2}(?:\.\d{3})*,\d{2}|0\d*,\d+)$").unwrap();
let string = "0,000001
0,000000001
1,00
1.000,00
0,1000000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}