import Foundation
let pattern = #"(?i)(?>.*?)(nugenix|cialis|somethingelse)(?>.*?@)(?!.*?(nugenix|cialis|somethingelse))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
// Match
Return-Path: <get-some-nugenix-for-health@whatever.yooooo.com>
Return-Path: <get-some-nugenix@-sakana15.com>
Return-Path: <nugenix-for-health@-sakana15.com>
<anycharacters+somethingelse+anyothercharacters+@
// No match - Banned words in Sender and Domain
Return-Path: <get-some-nugenix-for-health@whatnugenixever.yooooo.com>
Return-Path: <get-some-nugenix-for-health@nugenixwhatever.yooooo.com>
Return-Path: <get-some-nugenix-for-health@whatever.yooooo.comnugenix>
Return-Path: <get-some--for-healthnugenix@whatnugenixever.yooooo.com>
Return-Path: <nugenixget-some-for-health@nugenixwhatever.yooooo.com>
// No Match - Banned words only in domain
Return-Path: <get-some-for-health@whatever.yooooo.com>
Return-Path: <get-some-for-health@nugenixwhatever.yooooo.com>
Return-Path: <get-some-for-health@whatevernugenix.yooooo.com>
Return-Path: <get-some-for-health@whatever.yooooo.comnugenix>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)