Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
"
^\p{Zs}*(<(?:/?[xg]\d|[xg]\d/)>\p{Zs}*)+\p{Zs}*$
"
gm
Input 1
1
New
<x1/> <x1/><x2/> <g1></g1> <x1/><g1></g1> <x1/><x1/><x2/> <x1/> <x1/><x2/> <g1></g1> <x1/><g1></g1> <x1/><x1/><x2/> <x1/> <x1/><x2/> <g1></g1> <g1> </g1> <g1> </g1> <g1> </g1> <x1/><x1/><x2/> <x1/> <x1/><x2/> <x1/><x1/> <x2/> <x1/><x1/> <x2/> <x1/> <x1/> <x2/> <x1/> <x1/> <x2/> <x1/> <x1/> <x2/> <x1/> <x1/> <x2/> <x1/><x1/> <x2/> <x1/><x1/> <x2/> <x1/> <x1/><x2/> <g1></g1> <x1/><g1></g1> <x1/><x1/><x2/> <x1/> <x1/><x2/> <g1></g1> <g1> </g1> <g1> </g1> <g1> </g1> <x1/><x1/><x2/> <x1/> <x1/><x2/> <x1/><x1/> <x2/> <x1/><x1/> <x2/> <x1/> <x1/> <x2/> <x1/> <x1/> <x2/> <x1/> <x1/> <x2/> <x1/> <x1/> <x2/> <x1/><x1/> <x2/> <x1/><x1/> <x2/>