# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bItem\s+5\.02\s*([\w\W]*?)(?=\s*(?:Item\s+(?:[89]\.01|5\.0[37])|SIGNATURES?|Pursuant\s+to\s+the\s+requirements\s+of\s+the\s+Securities\s+Exchange\s+Act\s+of\s+1934)\b)"
test_str = ("Item 5.02 text\n"
"text\n"
"text\n"
" Item 8.01\n"
"Item 5.02 text\n"
"text\n"
" Item 9.01\n"
"Item 5.02 text\n"
"text\n"
" Item 5.03\n"
"Item 5.02 text\n"
"text\n"
" Item 5.07\n"
"Item 5.02 text\n"
"text\n"
" SIGNATURES\n"
"Item 5.02 text\n"
"text\n"
" SIGNATURE\n"
"Item 5.02 text\n"
"text\n"
" Pursuant to the requirements of\n"
" the Securities Exchange Act of 1934")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.