$re = '/[a-zA-Z]:(\\\\[^\:\\\\]+)\\\\Microsoft\\\\Windows Defender\\\\[a-z-A-Z]latform\\\\[a-zA-Z0-9]{0,8}.[a-zA-Z0-9]{0,8}.[a-zA-Z0-9]{0,8}.[a-zA-Z0-9]{0,8}-[a-zA-Z0-9]{0,8}\\\\MsMpEng.exe/m';
$str = 'C:\\ProgramData\\Microsoft\\Windows Defender\\Platform\\4.18.1806.18062-0\\MsMpEng.exe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);