# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/&#\w+;(*SKIP)(*F)|;/<NEW>/g;t' <<< "ć;
Johć; Smith <js@comms.com>;
;boomʿ;woopwoop;
;"