package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`&#\w+;(*SKIP)(*F)|;`)
var str = `ć;
Johć; Smith <js@comms.com>;
;boomʿ;woopwoop;
;`
var substitution = "<NEW>"
fmt.Println(re.ReplaceAllString(str, substitution))
}