re = /&#\w+;(*SKIP)(*F)|;/
str = 'ć;
Johć; Smith <js@comms.com>;
;boomʿ;woopwoop;
;'
subst = '<NEW>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result