import Foundation
let pattern = ##"&#\w+;(*SKIP)(*F)|;"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
ć;
Johć; Smith <js@comms.com>;
;boomʿ;woopwoop;
;
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<NEW>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)