re = /(?<=`)\w+|(?<=^`.*[^{}\r\n]+)\b[^{}` \r\n]+/m
str = 'old: ^[`]\\K | (?<=\\G) (?>{.*?}|[^`]) \\K [^{}`]+
`{string} with {exluded} words 12 nums`
oops
`string {with} {exluded} words 12 nums`
`string ww {exluded} words 12 nums`
"quoted {string} with {exluded} words and 12 nums"
"quoted string {with} exluded {words} and {12} nums"
quoted {string} with {exluded} words and 12 nums
quoted string {with} exluded {words} and {12} nums'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end