const regex = /^(?!(?:1-)?(?:\$|#|(?:\((8(?:00|55|66|77|88))\)|(?1))))\(?[\s.-]*([0-9]{3})?[\s.-]*\)?[\s.-]*[0-9]{3}[\s.-]*[0-9]{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(?:1-)?(?:\\$|#|(?:\\((8(?:00|55|66|77|88))\\)|(?1))))\\(?[\\s.-]*([0-9]{3})?[\\s.-]*\\)?[\\s.-]*[0-9]{3}[\\s.-]*[0-9]{4}$', 'gm')
const str = `1-800-450-7006
1 (800) 450-7006
1(800) 450-7006
(800) 450-7006
800 450-7006`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}