$re = '/^.*(?=\/test reports\s)/m';
$str = '/docs/reports/test reports/document1.docx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);