#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z]:Y(,[A-Z]:Y)*$"
Local $sString = "S:Y,P:Y,T:Y,A:Y" & @CRLF & _
"S:Y,P:Y,T:Y,A:Y,C:Y" & @CRLF & _
"S:Y,P:Y,T:Y,A:Y,C:Y,D:Y" & @CRLF & _
"A:Y" & @CRLF & _
"B:Y" & @CRLF & _
"D:Y,F:Y" & @CRLF & _
"" & @CRLF & _
"All the following should never match. Cos 1 or more of them has :N." & @CRLF & _
"" & @CRLF & _
"S:Y,P:N,T:Y,A:Y" & @CRLF & _
"S:Y,P:Y,T:Y,A:Y,C:N" & @CRLF & _
"S:Y,P:Y,T:N,A:Y,C:N,D:Y" & @CRLF & _
"A:N" & @CRLF & _
"B:N" & @CRLF & _
"D:Y,F:N"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")