use strict;
my $str = 'Debuted 11/03/1958 and peaked at #38 on the Hot 100 Chart. Source: Pop Annual. Label/Number: Ace 551. Date Peaked: 12/01/1958.
Debuted 11/30/1957 and peaked at #1 on the Hot 100 Chart. Source: Pop Annual. Label/Number: ABC-Paramount 9871. Date Peaked: 12/28/1957.
Debuted 09/15/1958 and peaked at #1 on the Hot 100 Chart. Source: Pop Annual. Label/Number: MGM 12677. Date Peaked: 11/10/1958.';
my $regex = qr/Debuted (.*) and peaked at (.*) on the (.*)\. Source: (.*)\. Label\/Number: (.*)\. Date Peaked: (.*)\./mp;
my $subst = '$1==$2==$3==$4==$5==$6';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";