// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Debuted (.*) and peaked at (.*) on the (.*)\. Source: (.*)\. Label\/Number: (.*)\. Date Peaked: (.*)\.").unwrap();
let string = "Debuted 11/03/1958 and peaked at #38 on the Hot 100 Chart. Source: Pop Annual. Label/Number: Ace 551. Date Peaked: 12/01/1958.
Debuted 11/30/1957 and peaked at #1 on the Hot 100 Chart. Source: Pop Annual. Label/Number: ABC-Paramount 9871. Date Peaked: 12/28/1957.
Debuted 09/15/1958 and peaked at #1 on the Hot 100 Chart. Source: Pop Annual. Label/Number: MGM 12677. Date Peaked: 11/10/1958.";
let substitution = "$1==$2==$3==$4==$5==$6";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}