use strict;
my $str = 'logo
[https://app.discountdata.ng/assets/images/full-logo.png]https://app.discountdata.ng
Discount Data - Nigeria\'s topmost enterprise solution to your telecom needs.
NOTIFICATION ALERT
Hi staffdd,
Glo CORPORATE GIFTING 1GB - 30 Days to 08110768733 Reference ID Is :
#202406131022Y5WSUG49ERTYGT666aba5d7dbd3
If you wish to option out from this kind of mail, please contact us or ignore
this message.
If you face any issues, please contact us at help@discountdata.ng
(c) 2024 Discount Data. All rights reserved.
This email was sent to you as a registered member of Discount Data
[https://app.discountdata.ng]. Thank You.';
my $regex = qr/(?<=\n)(?<match>.+?(?<phone>\d[\d\s]{7,}).+Reference.+id[\w\W]+#(?<ref>\w+\b))/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}