import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\*\\*([^~*]*?~~(?!~))(?:(?1){2})*[^~*]*?\\*\\*";
final String string = "MATCH THESE:\n"
+ "** basic ~~ case **\n"
+ "**~~**\n"
+ "** intermediate ~~ ~~ ~~ **\n"
+ "** this ~~ is ~~ more~~ ~~complex ~~ **\n\n"
+ "BUT NOT THESE:\n"
+ "** three ~~~ tildes **\n"
+ "** even ~~ number ~~ **\n"
+ "**some** **stuff~~more**\n"
+ "**no~~~~~~**\n"
+ "** ~~~~ ~~~~~~ **";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}