import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[6789]\\d{8}$";
final String string = "630222544\n"
+ "941641893\n"
+ "625233988\n"
+ "724903785\n"
+ "816794701\n\n"
+ "910 50 78 87\n"
+ "928-93-38-79\n"
+ " 628238339\n"
+ "275766639\n"
+ "+34 969 97 22 01\n"
+ "792199000 \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}