const regex = /^[6789]\d{8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[6789]\\d{8}$', 'gm')
const str = `630222544
941641893
625233988
724903785
816794701
910 50 78 87
928-93-38-79
628238339
275766639
+34 969 97 22 01
792199000
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}