use strict;
my $str = '630222544
941641893
625233988
724903785
816794701
910 50 78 87
928-93-38-79
628238339
275766639
+34 969 97 22 01
792199000
';
my $regex = qr/^[6789]\d{8}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}