import re
regex = re.compile(r"^[6789]\d{8}$", flags=re.MULTILINE)
test_str = ("630222544\n"
"941641893\n"
"625233988\n"
"724903785\n"
"816794701\n\n"
"910 50 78 87\n"
"928-93-38-79\n"
" 628238339\n"
"275766639\n"
"+34 969 97 22 01\n"
"792199000 \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")