// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[6789]\d{8}$").unwrap();
let string = "630222544
941641893
625233988
724903785
816794701
910 50 78 87
928-93-38-79
628238339
275766639
+34 969 97 22 01
792199000
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}