re = /<VAR name="faxstatus" value="(?<faxstatus>.*?)".*?/m
str = '<?xml version="1.0" encoding="UTF-8" standalone="yes"?><ANGELXML><MESSAGE><PLAY><PROMPT type="text"/></PLAY></MESSAGE><VARIABLES><VAR name="faxstatus" value="success"/></VARIABLES></ANGELXML>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end