// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<VAR name="faxstatus" value="(?<faxstatus>.*?)".*?"#).unwrap();
let string = "<?xml version=\"1.0\" encoding=\"UTF-8\" standalone=\"yes\"?><ANGELXML><MESSAGE><PLAY><PROMPT type=\"text\"/></PLAY></MESSAGE><VARIABLES><VAR name=\"faxstatus\" value=\"success\"/></VARIABLES></ANGELXML>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}