package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\<[^<]*\\\>`)
var str = `test\<string1\>again\<string2\>blabla`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}