Non-Capturing Group(?:""\s+?Controle\s*Fiscal[\w\W]+?)? ?repeats the group contents below at most once:
\s+?a Unicode whitespace character, repeated at least once
Controlethe literal text Controle (case sensitive) \s*a Unicode whitespace character, repeated any number of times
Fiscalthe literal text Fiscal (case sensitive) +?matches at least one character from the set below:
\wa Unicode word character
\Wany character that is not a Unicode word character
\s+a Unicode whitespace character, repeated at least once
Group NomeUc(?<NomeUc>[\w\W]+?) +?matches at least one character from the set below:
\wa Unicode word character
\Wany character that is not a Unicode word character
$end of line
Non-Capturing Group(?:.*?) .*?any Unicode character, repeated any number of times
\s+?a Unicode whitespace character, repeated at least once
Group Cnpj(?<Cnpj>\d{14}) \d{14}a Unicode decimal digit, repeated exactly 14 times
\s*a Unicode whitespace character, repeated any number of times
Non-Capturing Group(?:.*?) .*?any Unicode character, repeated any number of times
Group MesReferencia(?<MesReferencia>\d{2}\/\d{4}) \d{2}a Unicode decimal digit, repeated exactly 2 times
\/the literal / (4710 / 578 / 2F16)
\d{4}a Unicode decimal digit, repeated exactly 4 times
Non-Capturing Group(?:.*?) .*?any Unicode character, repeated any number of times
Group DtEmissao(?<DtEmissao>\d{2}\/\d{2}\/\d{4}) \d{2}a Unicode decimal digit, repeated exactly 2 times
\/the literal / (4710 / 578 / 2F16)
\d{2}a Unicode decimal digit, repeated exactly 2 times
\/the literal / (4710 / 578 / 2F16)
\d{4}a Unicode decimal digit, repeated exactly 4 times
Non-Capturing Group(?:.*?) .*?any Unicode character, repeated any number of times
\d{2}a Unicode decimal digit, repeated exactly 2 times
\/the literal / (4710 / 578 / 2F16)
\d{2}a Unicode decimal digit, repeated exactly 2 times
\/the literal / (4710 / 578 / 2F16)
\d{4}a Unicode decimal digit, repeated exactly 4 times
\s+a Unicode whitespace character, repeated at least once
Group NumFatura(?<NumFatura>\d+) \d+a Unicode decimal digit, repeated at least once
\s+a Unicode whitespace character, repeated at least once
Non-Capturing Group(?:.*?) .*?any Unicode character, repeated any number of times
Group ExternalCode(?<ExternalCode>\d+-\d+) \d+a Unicode decimal digit, repeated at least once
-the literal - (4510 / 558 / 2D16)
\d+a Unicode decimal digit, repeated at least once
\s+a Unicode whitespace character, repeated at least once
Non-Capturing Group(?:.*?) .*?any Unicode character, repeated any number of times
Group DtVencimento(?<DtVencimento>\d{2}\/\d{2}\/\d{4}) \d{2}a Unicode decimal digit, repeated exactly 2 times
\/the literal / (4710 / 578 / 2F16)
\d{2}a Unicode decimal digit, repeated exactly 2 times
\/the literal / (4710 / 578 / 2F16)
\d{4}a Unicode decimal digit, repeated exactly 4 times
\s+a Unicode whitespace character, repeated at least once
Non-Capturing Group(?:.*?) .*?any Unicode character, repeated any number of times
Group VlrTotalFatura(?<VlrTotalFatura>[0-9\.]+,?\d*) +matches at least one character from the set below:
0-9one character from 0 (4810) to 9 (5710)
\.the literal . (4610 / 568 / 2E16)
,?optionally matches the literal , (4410 / 548 / 2C16)
\d*a Unicode decimal digit, repeated any number of times
Non-Capturing Group(?:.*?) .*?any Unicode character, repeated any number of times
Constathe literal text Consta (case sensitive) \sa Unicode whitespace character
nestathe literal text nesta (case sensitive) \sa Unicode whitespace character
faturathe literal text fatura (case sensitive) \s*a Unicode whitespace character, repeated any number of times
Rthe literal R (8210 / 1228 / 5216) (case sensitive)
.any Unicode character
\sa Unicode whitespace character
Group VlrPisCofins(?<VlrPisCofins>[0-9\.]+,?\d*) +matches at least one character from the set below:
0-9one character from 0 (4810) to 9 (5710)
\.the literal . (4610 / 568 / 2E16)
,?optionally matches the literal , (4410 / 548 / 2C16)
\d*a Unicode decimal digit, repeated any number of times
\sa Unicode whitespace character
referentesthe literal text referentes (case sensitive) \sa Unicode whitespace character
athe literal a (9710 / 1418 / 6116) (case sensitive)
\sa Unicode whitespace character
Non-Capturing Group(?:.*?) .*?any Unicode character, repeated any number of times
Group AliqPis(?<AliqPis>[0-9\.]+,?\d*) ,?optionally matches the literal , (4410 / 548 / 2C16)
\d*a Unicode decimal digit, repeated any number of times
%the literal % (3710 / 458 / 2516)
\sa Unicode whitespace character
dethe literal text de (case sensitive) \sa Unicode whitespace character
PISthe literal text PIS (case sensitive) \sa Unicode whitespace character
ethe literal e (10110 / 1458 / 6516) (case sensitive)
\sa Unicode whitespace character
Non-Capturing Group(?:.*?) Group AliqCofins(?<AliqCofins>[0-9\.]+,?\d*) %the literal % (3710 / 458 / 2516)
\sa Unicode whitespace character
dethe literal text de (case sensitive) \sa Unicode whitespace character
COFINSthe literal text COFINS (case sensitive) Non-Capturing Group(?:.*?) \)the literal ) (4110 / 518 / 2916)
\s+a Unicode whitespace character, repeated at least once
\d+a Unicode decimal digit, repeated at least once
\s+a Unicode whitespace character, repeated at least once
Non-Capturing Group(?:\d+)? \s+a Unicode whitespace character, repeated at least once
Group VlrBaseIcms(?<VlrBaseIcms>[0-9\.]+,?\d*) Non-Capturing Group(?:.*?) \s+a Unicode whitespace character, repeated at least once
Group AliqIcms(?<AliqIcms>\d+) \s+a Unicode whitespace character, repeated at least once
Non-Capturing Group(?:.*?) ^start of line
Group DContratadaFp(?<DContratadaFp>[0-9\.]+,?\d*) \s+a Unicode whitespace character, repeated at least once
Non-Capturing Group(?:.*?) ,?optionally matches the literal , (4410 / 548 / 2C16)
\d*a Unicode decimal digit, repeated any number of times
\s+a Unicode whitespace character, repeated at least once
Group VlrIcms(?<VlrIcms>[0-9\.]+,?\d*) \s+a Unicode whitespace character, repeated at least once
Non-Capturing Group(?:.*?) \s+a Unicode whitespace character, repeated at least once
Group DataLeituraAtual(?<DataLeituraAtual>\d{2}\/\d{2}\/\d{4}) \s+a Unicode whitespace character, repeated at least once
Non-Capturing Group(?:.*?) Group DataLeituraAnterior(?<DataLeituraAnterior>\d{2}\/\d{2}\/\d{4}) \s+a Unicode whitespace character, repeated at least once
Non-Capturing Group(?:.*?) \s+a Unicode whitespace character, repeated at least once
Group LeituraAtualCFp(?<LeituraAtualCFp>[0-9\.]+,?\d*) \s+a Unicode whitespace character, repeated at least once
Non-Capturing Group(?:.*?) Group LeituraAnteriorCFp(?<LeituraAnteriorCFp>[0-9\.]+,?\d*) \s+a Unicode whitespace character, repeated at least once
Non-Capturing Group(?:.*?) Group ConstanteConsumoFp(?<ConstanteConsumoFp>[0-9\.]+,?\d*) \s+a Unicode whitespace character, repeated at least once
Non-Capturing Group(?:.*?) Group CMedidoFp(?<CMedidoFp>[0-9\.]+,?\d*) \s+a Unicode whitespace character, repeated at least once
Non-Capturing Group(?:.*?) Group LeituraAtualCP(?<LeituraAtualCP>[0-9\.]+,?\d*) \s+a Unicode whitespace character, repeated at least once
Non-Capturing Group(?:.*?) Group LeituraAnteriorCP(?<LeituraAnteriorCP>[0-9\.]+,?\d*) \s+a Unicode whitespace character, repeated at least once
Non-Capturing Group(?:.*?) Group ConstanteConsumoP(?<ConstanteConsumoP>[0-9\.]+,?\d*) \s+a Unicode whitespace character, repeated at least once
Non-Capturing Group(?:.*?) Group CMedidoP(?<CMedidoP>[0-9\.]+,?\d*) Non-Capturing Group(?:.*?)