using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\[\^)([^\]\s\p{C}]+)(\])\ (\P{C}*(?:\n(?!\n[\[\n])\P{C}*)*)";
string input = @"Pseudo-example:
Sentence of the first [^a]paragraph. Sentence[^b] of the first[^b] paragraph[^1]. Sentence of the first[^1] paragraph. Sentence[^1] of the first paragraph. Sentence of the first paragraph. Sentence of the first paragraph. Sentence of the first paragraph.
[^a] Sentence of a long margin note's body that refers to the word ""paragraph"".
[^1] Sentence of the first paragraph of the footnote. Sentence of the first paragraph of the footnote. Sentence of the first paragraph of the footnote. Sentence of the first paragraph of the footnote.
Sentence of the second paragraph of the footnote. Sentence of the second paragraph of the footnote. Sentence of the second paragraph of the footnote. Sentence of the second paragraph of the footnote.
Sentence of the third and the last paragraph of the footnote and two empty lines after it!
Sentence[^1] of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph.
[^b] Footnote at the end of the file. Footnote at the end of the file. Footnote at the end of the file.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}