re = /\b(?:crossing_success|series120_count)\[(\d+)]/m
str = 'x <- "
series120_count[1]; crossing_success[2]; tag_comments[small]
"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end