import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "While +([^\\n\\;]+);?((?:[ \\t]*(?!Wend)(?:\\S+[ \\t]*)*\\n)+[ \\t]*)Wend[ \\t]*\\;?";
final String string = " While x > 0;\n"
+ " string y = x Mod 2;\n"
+ " ret = y + ret;\n"
+ " x = x / 2\n"
+ " Wend;\n"
+ " \n"
+ "While Not Eof(file);\n"
+ "x = x / 2\n"
+ " Wend;\n\n"
+ "While Wend => while{}";
final String subst = "while ($1){$2}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}