use strict;
my $str = ' While x > 0;
string y = x Mod 2;
ret = y + ret;
x = x / 2
Wend;
While Not Eof(file);
x = x / 2
Wend;
While Wend => while{}';
my $regex = qr/While +([^\n\;]+);?((?:[ \t]*(?!Wend)(?:\S+[ \t]*)*\n)+[ \t]*)Wend[ \t]*\;?/mp;
my $subst = 'while ($1){$2}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";