import Foundation
let pattern = #"While +([^\n\;]+);?((?:[ \t]*(?!Wend)(?:\S+[ \t]*)*\n)+[ \t]*)Wend[ \t]*\;?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
While x > 0;
string y = x Mod 2;
ret = y + ret;
x = x / 2
Wend;
While Not Eof(file);
x = x / 2
Wend;
While Wend => while{}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"while ($1){$2}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)