package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^: ]+)[: ]+([^; ]+)[; ]*`)
var str = `background #2b2b2b; color: #FFFFFF`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}