#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.)(.*?)([^@]?)(?=@[^@]+$)"
Local $sString = "a@example.com" & @CRLF & _
"ab@example.com" & @CRLF & _
"abc@example.com" & @CRLF & _
"abcd@example.com" & @CRLF & _
"abcde@example.com" & @CRLF & _
"abcdef@example.com" & @CRLF & _
"abcdefg@example.com" & @CRLF & _
"Ф@example.com" & @CRLF & _
"ФѰ@example.com" & @CRLF & _
"ФѰД@example.com" & @CRLF & _
"ФѰДӐӘӔӺ@example.com" & @CRLF & _
""a@tricky@one"@example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")