using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.)(.*?)([^@]?)(?=@[^@]+$)";
string input = @"a@example.com
ab@example.com
abc@example.com
abcd@example.com
abcde@example.com
abcdef@example.com
abcdefg@example.com
Ф@example.com
ФѰ@example.com
ФѰД@example.com
ФѰДӐӘӔӺ@example.com
""a@tricky@one""@example.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}