import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.)(.*?)([^@]?)(?=@[^@]+$)";
final String string = "a@example.com\n"
+ "ab@example.com\n"
+ "abc@example.com\n"
+ "abcd@example.com\n"
+ "abcde@example.com\n"
+ "abcdef@example.com\n"
+ "abcdefg@example.com\n"
+ "Ф@example.com\n"
+ "ФѰ@example.com\n"
+ "ФѰД@example.com\n"
+ "ФѰДӐӘӔӺ@example.com\n"
+ "\"a@tricky@one\"@example.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}