package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+234(7[0]|8[01]|9[01])\d.{07,08}$`)
var str = `+23470456
+2348145646767`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}