import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=1\\n:).*";
final String string = "Name1\n"
+ ":100%\n"
+ "Name2\n"
+ ":234%\n"
+ "Name3\n"
+ ":\n"
+ "Name4\n"
+ ":63%\n"
+ "Name5\n"
+ ":12%";
final String subst = "<10%";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}