const regex = /(https:\/\/www\.test\.com\/items\/)[0-9]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https:\\\/\\\/www\\.test\\.com\\\/items\\\/)[0-9]+', 'g')
const str = `https://www.test.com/items/1.html
https://www.test.com/items/1123.html
https://www.test.com/items/234.html
https://www.bar.com/items/234.html
https://www.test.com/items.html
https://www.bar.com/items/234.html
https://www.test.com/items.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}