package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[a-zA-Z]{2,}\d*|[a-zA-Z]\d{2,})$`)
var str = `BadUs3rnam3
c57bT3
aa
aa
a111111
a1
11`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}