// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[a-zA-Z]{2,}\d*|[a-zA-Z]\d{2,})$").unwrap();
let string = "BadUs3rnam3
c57bT3
aa
aa
a111111
a1
11";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}