use strict;
my $str = 'phrase1 phrase2 phrase3
phrase4 phrase5 phrase6';
my $regex = qr/^.*[ ]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";