import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "CRLF\\n(?!Conduit)";
final String string = "Conduit 1 CRLF\n"
+ "10 CRLF\n"
+ "23 CRLF\n"
+ "Conduit 1 CRLF\n"
+ "22 CRLF\n"
+ "12 CRLF\n"
+ "Conduit 2 CRLF";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}